• 5,785,378
    REGISTERED
  • 38,373
    ONLINE NOW

Galaxy Note 10.1 Receives Official CM10.1 Nightlies

Galaxy Note 10.1 Receives Official CM10.1 Nightlies

Anyone who has spent time on XDA, or in the Android community at large, knows that when a device receives inclusion in CyanogenMod’s device tree, it is a beautiful day. This is because CM support ensures that the device will have a longer-than-manufacturer-intended lifespan. This of course depends on the manufacturer providing the tools and documentation necessary for development to occur. In many cases, OEMs do a pretty good job at publishing the documentation for instances in which they deviate from the reference design of a device’s board. Other times, however, manufacturers seem to go into brain fart-mode when it comes to this.

Samsung, in their infinite wisdom, has made it extremely difficult for devices based on the Exynos 4 reference design to receive CyanogenMod 10.x nightlies. This is not new news, as it’s been well-covered that Samsung continues to fail the community when it comes to devices based on their Exynos 4×12 devices (Galaxy S3, Galaxy Note 10.1, Galaxy Note 2, Galaxy Camera, Meizu MX). The sources from Samsung are consistently missing required pieces in order to be GPL-compliant, and recent investigations have found Gingerbread-remnants in their ICS sources.

All of that has not deterred XDA Recognized Developers espenfjo and Entropy512 from diligently laboring to bring the CM10.1 experience to the Galaxy Note 10.1. There have been obstacles, but they have pressed through. Thanks to their work, the Note 10.1 (N80o0 GSM and N8010/N8013 WiFi) recently began to receive CyanogenMod nightlies. As of the time of this posting, there are issues with Netflix working on CM10.1 but Entropy512 has put together a workaround for all Exynos 4 devices via the Xposed framework.

As is always the case, the typical disclaimers apply as CM10.1 is a work-in-progress, especially on these devices. So if you have a bug to report, make sure you post a logcat in the thread with a detailed description of what you were doing and what happened. In order to flash the builds, you will need to use either TWRP or  Entropy’s CWM build because they are the only ones that are confirmed to work at this time. If you receive an ‘assert failed‘ error message, you should first confirm that you are indeed using one of the two aforementioned recoveries.

_________
Want something on the XDA Portal? Send us a tip! -- Join us for xda:devcon 2014!
Advertisment
Advertisement

XDA TV: Most Recent Video

Buy/Sell on Swappa

  • Nexus 5 (Unlocked) buy | sell
  • Galaxy Note 3 (T-Mobile) buy | sell
  • HTC One M7 (Verizon) buy | sell
  • Galaxy S 5 (Unlocked) buy | sell
  • Nexus 7 2013 buy | sell
  • Swappa is the official marketplace of XDA