• 5,779,328
    REGISTERED
  • 49,683
    ONLINE NOW

Halo Popup on Any ROM Using Xposed

Difficulty:
1
Halo Popup on Any ROM Using Xposed

Paranoid Android’s revolutionary Halo has earned more than a few loyal users. The framework, which was made open source some time ago (1, 2), enables a fundamentally new kind of multitasking, which was previously impossible on Android.

Unfortunately, not every device has a suitable Paranoid Android port, so those wishing to get in on the Halo action are unfortunately left in the cold. This then prompted XDA Senior Member zst123 to leverage Recognized Developer rovo89‘s Xposed Framework (thread) as a delivery method to help bring part of what makes Paranoid Android so special to a larger number of devices.

Theoretically, zst123′s Xposed module should work on any device that is running Ice Cream Sandwich or later. This requirement is because the Xposed Framework itself only runs on Ice Cream Sandwich or later. More specifically, there are five classes from the API14 (ICS) SDK that are hooked by the module. Thus, as long as the ROM you are using doesn’t modify these, XHaloFloatingWindow will likely work.

If you wish to bring some of the Paranoid Android experience over to your unsupported device, head over to the original thread and give this a shot. That said, if your device has an official PA port already, we highly recommend giving the real thing a shot.

_________
Want something on the XDA Portal? Send us a tip! -- Join us for xda:devcon 2014!
Advertisment
Advertisement

XDA TV: Most Recent Video

Buy/Sell on Swappa

  • Nexus 5 (Unlocked) buy | sell
  • Galaxy Note 3 (T-Mobile) buy | sell
  • HTC One M7 (Verizon) buy | sell
  • Galaxy S 5 (Unlocked) buy | sell
  • Nexus 7 2013 buy | sell
  • Swappa is the official marketplace of XDA